Formatting Disappearing from Pictures and Tables

Get your Drupal questions answered here!

Formatting Disappearing from Pictures and Tables

Postby kcombs » Fri Jul 06, 2012 6:00 am

Each time I edit a page, the formatting disappears from the pictures and tables and they return to their default size and setup. The problem just started this week.

Thanks
Kristine
kcombs
 
Posts: 7
Joined: Thu Mar 17, 2011 9:37 am
 

Re: Formatting Disappearing from Pictures and Tables

Postby Madelynn » Fri Jul 06, 2012 8:17 am

Because certain permissions on editing can cause security breaches, we implemented some stricter guidelines, but it seems many subscribers are having problems with the loss of formatting.

Please try editing those pages now and see if the problem has cleared up. If not, it may be you need to remove old formatting before applying new. To remove formatting from text, etc., select the content and click on the Remove Format button on your WYSIWYG editor. It is the last button in the third section of the first row. It looks like an eraser. Then apply any new formatting you wish.

Madelynn
Madelynn
Site Admin
 
Posts: 138
Joined: Wed Feb 16, 2011 8:37 pm
Location: GingerFeet LLC
 

Re: Formatting Disappearing from Pictures and Tables

Postby Pete Morsch » Mon Feb 11, 2013 2:03 pm

I'm having the same problem. Checked to see if I'm inputting with full HTML, I am... and still, everytime I open a page to edit, the pictures completely fly off the handle.

Reformatting wouldn't be so bad - except for that it's horrible! I have to go through each picture to get it to fit right again. it is a nightmare!

What do I need to do to make the madness stop?
Pete Morsch
 
Posts: 20
Joined: Wed Jan 04, 2012 12:35 pm
 

Re: Formatting Disappearing from Pictures and Tables

Postby Pete Morsch » Mon Feb 11, 2013 2:05 pm

Also, removing formatting and applying new isn't really the issue. The issue is that any and all formatting is automatically removed, and adding it all back in again is a huge waste of time (especially when it doesn't turn out just right, and then you go back in and have to edit, and re-do all the changes again). Oof.
Pete Morsch
 
Posts: 20
Joined: Wed Jan 04, 2012 12:35 pm
 

Re: Formatting Disappearing from Pictures and Tables

Postby Pete Morsch » Mon Feb 11, 2013 2:07 pm

Case in point: this is what happens when I open the editor and try to add photos - I save, and all the photos have gone crazy:
https://www.scvhabitat.org/construction-update
Pete Morsch
 
Posts: 20
Joined: Wed Jan 04, 2012 12:35 pm
 

Re: Formatting Disappearing from Pictures and Tables

Postby Madelynn » Mon Feb 11, 2013 2:16 pm

If it wasn't happening before, the problem probably lies in the fact that you are applying new formatting over old. Try reading and implementing the suggestions in the post right below yours:

"You may need to remove old formatting before applying new. To remove formatting from text, etc., select the content and click on the Remove Format button on your WYSIWYG editor. It is the last button in the third section of the first row. It looks like an eraser. Then apply any new formatting you wish."

When you apply new formatting over and over again, multiple span tags (HTML) are added. After a while, the browser can't figure out what formatting to apply.

Best,
Madelynn
Madelynn
Site Admin
 
Posts: 138
Joined: Wed Feb 16, 2011 8:37 pm
Location: GingerFeet LLC
 

Re: Formatting Disappearing from Pictures and Tables

Postby Pete Morsch » Fri Apr 12, 2013 6:49 am

Madelynn -

Still having this issue - the "remove formatting" button doesn't seem to be one of the available tools on my WYSIWYG editor anymore???? I tried to find the drupal setting (under CKEditor menu?) to turn that button back on in the WYSIWYG, but it doesn't appear to be an option there, either... How do I properly remove formatting and add new, then? Should I just delete the pics as they stand and re-insert them fresh?
Pete Morsch
 
Posts: 20
Joined: Wed Jan 04, 2012 12:35 pm
 

Re: Formatting Disappearing from Pictures and Tables

Postby Madelynn » Fri Apr 12, 2013 7:51 am

Pete,

It is still there.
The "look" of the toolbar has been updated, but the same buttons are available, and you have a few more, like save, preview and print.
It is in the first row, third section. It has a capital "T". If you mouse over, you'll see the tooltip.

Best,
Madelynn
Madelynn
Site Admin
 
Posts: 138
Joined: Wed Feb 16, 2011 8:37 pm
Location: GingerFeet LLC
 

Re: Formatting Disappearing from Pictures and Tables

Postby Pete Morsch » Wed Apr 17, 2013 8:24 am

Madelynn -

Discovered the "remove formatting tool" with its classy new look! Hooray! And have applied it both to individual pictures (problem persists) and to the entire editable window (text, headings, the whole works) and yet, the problem persists. It's a danged nightmare to go back in with every edit and redo. If I miss an element on one picture, then i have to go back in and re-format for every picture... a vicious cycle of un-user friendliness.

So, what's the next step? Nuking the pages as they stand and starting fresh? Will I have to do that for everypage (i.e., rebuild the whole site, and if so, how long before the formatting reader gets confused and screws up again?) Sorry to be a downer... but it's really falling down on the job, here.

Let me know what we ought to do.
Pete Morsch
 
Posts: 20
Joined: Wed Jan 04, 2012 12:35 pm
 

Re: Formatting Disappearing from Pictures and Tables

Postby Madelynn » Wed Apr 17, 2013 9:01 am

Is this happening on every single page?
And what exactly is happening? When you return to the editing window, all formatting is removed?
If it's not happening on every page, can you give me a few example pages where it is?

Best,
Madelynn
Madelynn
Site Admin
 
Posts: 138
Joined: Wed Feb 16, 2011 8:37 pm
Location: GingerFeet LLC
 
 
Next

Return to Drupal How To

Who is online

Users browsing this forum: No registered users and 1 guest

cron